Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Engine stops running after a few minutes
#71
I know they are different, Its I just did not know which had failed, I'll suspect the camshaft position sensor as it rotates 2x more than crank sensor.

I'm just not familiar with chevy TBI's.

My 89 dodge is TBI but only has the 'distributor pick up coil'

which is basically the camshaft position sensor with a different name. Mine has no crankshaft position sensor.

Rock auto lists no 'ignition/distributor pick up coil' for a 96 chevy 3500 with a 5.7v, so its either the crank or camshaft position sensor that was faulty.

I bring this up as it seems either or, could fail and cause the same or very similar issues, might want to carry a spare of the other which did not fail(yet)

That a magnetic field sensing sensor, failed in front of someone's home where a relationship soon developed, can lead one to believe in things that science and logic cannot explain.
[-] The following 1 user says Thank You to sternwake for this post:
  • AbuelaLoca (07-27-2020)
Reply
#72
(07-26-2020, 03:55 PM)sternwake Wrote: Rock auto lists no 'ignition/distributor pick up coil' for a 96 chevy 3500 with a 5.7v, so its either the crank or camshaft position sensor that was faulty.



That a magnetic field sensing sensor, failed in front of someone's home where a relationship soon developed, can lead one to believe in things that science and logic cannot explain.

Stern,  I believe it's a 96 G30  see photo

And yes I believe it can happen.  I don't know if they are in Vegas however.   Big Grin


Attached Files Thumbnail(s)
   
Reply
#73
oops,  Once again I open mouth insert foot.  I checked other thread and it does show 3500.  My bad.  I go bed now.

I still believe it can happen. Smile
Reply
#74
I thought they ended the g10/20/30 series well before 1996, learned something new.

strange that the g30 lists ignition pickup module, but the express 3500 does not, I thought they'd be the same, one being a window passenger van and the other not? I don't know.

Eitherway, its fixed, and congrats to Roadtripp on both
Reply
#75
(06-30-2020, 10:12 AM)Roadtripp Wrote: Help.......I’ve been stranded for 3 days in Cashmere waiting to order parts and fix the G30. A kind person is letting me park in front and being moral support. The engine will start when it’s cold and run for 5-10 minutes then stop. It will not start again for a hour or two. Ive checked a bunch of possible causes and replaced the cap, rotor, & ignition pickup coil but none have fixed it. I could not see any spark or fuel spraying so assumed it was electrical no spark/no fuel issue. Someone said the fuel pump can be running but not pumping or the pump relay epoxy gets brittle and cracks and doesn’t relay power properly?? So I was thinking of buying a fuel pump pressure tester and see if the pressure is steady? I placed my ear to the fuel filler and can hear the pump whining. But I don’t really know what it is pumping. There was a code 54 (fuel pump circuit). 
 Other odd symptom is water dripping from tailpipe. I also wondered if my catalytic converter was getting plugged. 
 I also read the temperature sensor can confuse the computer if the sensor is malfunctioning. So I’m going to order one. 
 Any ideas and suggestions are most welcome.

Woke up this morning with a little clearer head.  I thought I remembered G30.  The original post of this thread.  The coil is inside the distributor and senses off the distributor shaft.  I go back to points and condensor at times.  Decades run together anymore.  Sad  Roadtripp described disassembly and assembly in post 63 of this thread.  I guess we'll have to wait till after the honeymoon to know for sure.  Does seem like a large bus/small engine for mountain driving. Might get heavy and all for the Mrs. stuff. Smile
Reply
#76
Nice! It's a great feeling when your latest fix finally solves the issue. Or maybe not in your case, I had figured you were taking the long approach to getting it fixed to spend more time with your new lady friend! Hope it works out on that avenue as well. Perhaps Gapper is right and you are on your honeymoon!
I didn't do it!
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)